Admin can no longer login / edit after update to 8.3.4

Hi all,

had tried Grafana 8.3.3 for a while on my Ubuntu 20.04 LTS server successfully.

Yesterday, upgraded to 8.3.4.

Since then, I still can login as admin with my admin password, but Grafana still shows the login button in the lower left corner (and not the admin account picture as so far).
Of course, I cannot edit any dash/panel.

Resetting admin password via CLI to a new one gives no solution.

cd /usr/share/grafana/
grafana-cli admin reset-admin-password admin
INFO[01-21|09:55:30] The state of unified alerting is still not defined. The decision will be made during as we run the database migrations logger=settings
WARN[01-21|09:55:30] falling back to legacy setting of ‚Äėmin_interval_seconds‚Äô; please use the configuration option in the unified_alerting section if Grafana 8 alerts are enabled. logger=settings
INFO[01-21|09:55:30] Config loaded from logger=settings file=/usr/share/grafana/conf/defaults.ini
INFO[01-21|09:55:30] Config loaded from logger=settings file=/etc/grafana/grafana.ini
INFO[01-21|09:55:30] Config overridden from command line logger=settings arg=‚Äúdefault.paths.data=/var/lib/grafana‚ÄĚ
INFO[01-21|09:55:30] Config overridden from command line logger=settings arg=‚Äúdefault.paths.logs=/var/log/grafana‚ÄĚ
INFO[01-21|09:55:30] Config overridden from command line logger=settings arg=‚Äúdefault.paths.plugins=/var/lib/grafana/plugins‚ÄĚ
INFO[01-21|09:55:30] Config overridden from command line logger=settings arg=‚Äúdefault.paths.provisioning=/etc/grafana/provisioning‚ÄĚ
INFO[01-21|09:55:30] Path Home logger=settings path=/usr/share/grafana
INFO[01-21|09:55:30] Path Data logger=settings path=/var/lib/grafana
INFO[01-21|09:55:30] Path Logs logger=settings path=/var/log/grafana
INFO[01-21|09:55:30] Path Plugins logger=settings path=/var/lib/grafana/plugins
INFO[01-21|09:55:30] Path Provisioning logger=settings path=/etc/grafana/provisioning
INFO[01-21|09:55:30] App mode production logger=settings
INFO[01-21|09:55:30] Connecting to DB logger=sqlstore dbtype=sqlite3
INFO[01-21|09:55:30] Starting DB migrations logger=migrator
INFO[01-21|09:55:30] migrations completed logger=migrator performed=0 skipped=377 duration=1.009675ms

Admin password changed successfully :heavy_check_mark:

Resetting admin password to admin gives me the password change dialog, but on save I get the two error messages: " Invalid or expired reset password code" and ‚ÄúUnauthorized‚ÄĚ

This happens on latest Firefox (96) and latest Edge (97) browsers. Caches cleared.

Any help available?

New finding:
Connect from another host with same Firefox / Edge version is fine.
Difference:
Working host is Win10 21H1
Not working host is Win10 21H2
Clueless…

Found the solution:
in grafana.ini I had previously set for an embedding application

cookie_samesite: none

Changing it back to the default (lax) fixed at least the login problem!

But, what caused today my problems is still weird to me…

1 Like

Thanks for sharing your issue and the fix. I was in the same situation and it worked for me.

The client-side browser console message Cookie ‚Äúgrafana_session‚ÄĚ rejected because it has the ‚ÄúSameSite=None‚ÄĚ attribute but is missing the ‚Äúsecure‚ÄĚ attribute and the server-side syslog entry Failed to look up user based on cookie had sent me on a wild goose chase.

Perhaps you could add [Solved] to the title.

Can you give me a hint how to add [Solved] to the title? I found no quick way, but I am new here…

I would have assumed you could click the pencil icon on the first post and edit the subject. I tried it on a post of mine but I also cannot edit the subject. On the other hand, I see topics which have been edited. I guess I’ll withdraw my suggest. Sorry.