Unable to listen on localhost

Hi, i have some troubles configuring Loki.

It’s a single instance (target=all) and I would like to set grpc_listen_address: 127.0.0.1 in order to avoid opening public ports. Unfortunately this setting causes various components to break, which are still connecting to the PUBLIC_IP (replaced for privacy reasons) instead of 127.0.0.1:

Mar 28 07:29:22 goedel loki[479461]: level=error ts=2022-03-28T05:29:22.551514726Z caller=scheduler_processor.go:199 org_id=fake msg="error notifying frontend about finished query" err="rpc error: code = Unavailable desc = connection error: desc = \"transport: Error while dialing dial tcp PUBLIC_IP:9096: connect: connection refused\"" frontend=PUBLIC_IP:9096
Mar 28 07:29:26 goedel loki[479461]: level=warn ts=2022-03-28T05:29:26.954879375Z caller=pool.go:184 msg="removing frontend failing healthcheck" addr=PUBLIC_IP:9096 reason="rpc error: code = Unavailable desc = connection error: desc = \"transport: Error while dialing dial tcp PUBLIC_IP:9096: connect: connection refused\""

The setting ring.instance_address is set to 127.0.0.1 as well using the inmemory ring.

Thanks for your help!

Best Regards,
Christoph

I find solution just adding: instance_addr: 127.0.0.1 to the common block.