[solved]Value # in my legend labels

Running Graf 9.2.4, on RHEL 7.9

I’m having trouble getting my query legend labels to display properly. Whatever I put in Query/Options/Legends (PACE-ICE), that does not display in my legend. Instead, by default Query A shows the label in the legend: “Value #A

I can change the query name (Defaults to A, B, C, etc.), so changed the name to “PACE-ICE” (tried with/without quotes). Instead of simply displaying that string, I get “Value #PACE-ICE” as the label for the query. I do not want the clutter of “Value #” pre-pended to my label string.

Why does Query/Options/Legends not display the string I want for the query, and most importantly, how do I get a clean label for my query?

Hi @gregbeyer

Have you tried using overrides, like this?

1 Like

Hi @grant2, thank you, that worked. IDK why the normal way of setting legend labels didn’t work this time, but any work-around is fine. I haven’t used overrides before, I’ll look at where I can use these to make my other charts even cleaner.



Hi @gregbeyer

Honestly, I could not tell you why the normal way works sometimes and others it does not. I think it depends on the datasource and visualization and maybe other factors (like how the query is returning the names of each series).