Proxy Pass - nginx - domain - origin not allowed

I’m trying to setup a proxy pass with nginx to point a subdomain to my grafana server instance.

Currently got the following nginx config and part of the grafana.ini config below.

This points me to the grafana server as expected and I can login. When I go to view a dashboard I get error origin not allowed.

How do I fix this?

server {
        listen 80;
        location / {
                proxy_pass      http://localhost:3000/;
# Protocol (http, https, h2, socket)
;protocol = http

# The ip address to bind to, empty will bind to all interfaces
;http_addr =

# The http port  to use
;http_port = 3000

# The public facing domain name used to access grafana from a browser
;domain =

# Redirect to correct domain if host header does not match domain
# Prevents DNS rebinding attacks
;enforce_domain = false

# The full public facing url you use in browser, used for redirects and emails
# If you use reverse proxy and sub path specify full url (with sub path)
;root_url = %(protocol)s://%(domain)s:%(http_port)s/

# Serve Grafana from subpath specified in `root_url` setting. By default it is set to `false` for compatibility reasons.
;serve_from_sub_path = false

Fixed - had to add the following to the nginx config

proxy_set_header Host;