OpenNMS datasource


I am trying to create a OpenNMS data source but getting error.
Below message i am getting in grafana logs.

t=2018-01-09T03:21:00-0500 lvl=info msg=“Request Completed” logger=context userId=1 orgId=1 uname=admin method=GET path=/api/datasources/proxy/8/rest/info status=404 remote_addr= time_ms=2 size=1382 referer=

Let me know what is going wrong.


Are you using the OpenNMS Helm app plugin or the deprecated OpenNMS data source plugin?

Looks like a configuration error as Grafana is saying that it cannot find rest/info. Have you got the correct URL? Here is an example for the deprecated plugin:


Hi Dan,

I am using OpenNMS Helm, please see my configuration.

Error message is same.


The problem is with your OpenNMS helm installation. Grafana is saying that it cannot find http://localhost:8980/opennms.

If you open that url in your browser, do you come to the OpenNMS login page?

Hi @daniellee I have tried the grafana for flow support but i am not able to view in OpenNMS application under Resource Graphs.
Grafana version i am using 7.5.7. even though i have tried plugin options.
i am one the user of OpenNMS & grafana. When i install the Grafana 7.5.7 along with plugin in ubuntu server 18.04. we are not getting node and other data value in dashboard.
what we have to do for getting data in dashboard?

We are unable to fetch the data in Grafana dashboard.