maxSeries returns lower max after zooming out

I have a single stat panel with the following metric:


$array is one NetApp array and $snapvault in this case is several nodes, each returning a value in minutes. I also have a graph panel on the same dashboard with the following metric:

aliasByNode(cmk.$array.$snapvault.Lag, 2)

So this results in line graph for each $snapvault, graphing the minutes value.

When I’m zoomed in, I see a line that goes up to 35 minutes on the graph panel. The single stat panel also shows 35 as the max of the series. This is correct. However, if I zoom out, I still see the line go up to the 35, but my single stat panel shows a lower max now. Why would that be?? I will attach screenshots if I can figure out how.




If you try and change Max data points under options to 1 for the max singlestat panels, does that solve your problem?


I don’t seem to have a “max data points” option.

Sorry should have said that it’s under the Metrics tab. To the right of datasource you’ll find an option button.


Ah, ok, found it. That didn’t help. It made it worse. My max time in the singlestat went down to 11 minutes when the graph clearly shows maximums over that.

Okay revert that. Didn’t think of that you have spark lines as well.

Please use the query inspector and include request/response information for both singlestat and graph panel when it’s working as expected and when you’re zooming out.