How to disable the console debug

Hi all,
I am using an docker-compose service like this to run my load tests:

    image: loadimpact/k6:0.36.0
      - ./telemetry-load-test/dist:/load-test:ro
      - haproxy1
      - haproxy2
      - haproxy3
      - influx
      - statsd
    command: run /load-test/ReportEventSimple.spec.js --tag test_space=telemetry_k --tag test_run=local --out statsd --discard-response-bodies -vu 1000 -q -d 10s 
      K6_STATSD_ADDR: statsd:8125

But even with that conf I am getting debug traces in the console like this:

2023-06-20 15:19:57 time="2023-06-20T13:19:57Z" level=debug msg="Pushing metrics to server" output=statsd samples=1

Is possible to disable that?


1 Like

Hi @ccrafael

Welcome to the community forum :wave:

I don’t know about older versions like 0.36.0. However, in recent versions, you have --log-output=none to disable log output.

I hope this helps.


1 Like

Thanks!! That is what I was looking for I got confused with -q flag.

1 Like