How do I enable TimeSeriesTable in configuration?

  • What Grafana version and what operating system are you using?

Grafana: 9.4.7
OS: Windows 10

  • What are you trying to achieve?

I am trying to enable the Sparkline in table feature

  • How are you trying to achieve it?

Added the following to default.ini configuration file:

# Enable timeseries spark line for table
timeSeriesTable = true

  • What happened?

I don’t see the new cell type override available to be selected.

  • What did you expect to happen?

I expected there to be a new Sparkline option available when selecting a cell type override.

  • Can you copy/paste the configuration(s) that you are having problems with?

As above.

  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.


  • Did you follow any online instructions? If so, what is the URL?

According to document, the Sparkline feature is only available in Grafana 9.5+.

I am using Sparkline on my dashboard, and I enabled the timeSeriesTable feature with environment variable GF_FEATURE_TOGGLES_ENABLE: "timeSeriesTable". If you want to enable it what configuration file, the config should be like as follows according to document:

enable = timeSeriesTable

@blueswen - You’re my hero, many thanks for your wisdom :slight_smile: