Grafana won't load after modifying the ini file and restarting services

Our grafana server was working well. We simply wanted to change the port. I followed the instructions for changing the default port for the system to 443 by Un-commenting the appropriate sections and then following the instructions for binding and service restarts.

sudo setcap ‘cap_net_bind_service=+ep’ /usr/sbin/grafana-server
sudo systemctl restart grafana-server

I even tried manually starting the service again, tried rebooting, and we simply cannot connect to the Web GUI any longer.
When I check the status, we see this:

● grafana-server.service - Grafana instance
Loaded: loaded (/lib/systemd/system/grafana-server.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Thu 2022-09-22 14:36:58 EDT; 19min ago
Process: 2640 ExecStart=/usr/sbin/grafana-server --config=${CONF_FILE} --pidfile=${PID_FILE_DIR}/ --packaging=deb cfg:default.paths.logs=${LOG_DIR}${DATA_DIR} cfg:def>
Main PID: 2640 (code=exited, status=203/EXEC)

Sep 22 14:36:58 cl1grafana systemd[1]: grafana-server.service: Scheduled restart job, restart counter is at 5.
Sep 22 14:36:58 cl1grafana systemd[1]: Stopped Grafana instance.
Sep 22 14:36:58 cl1grafana systemd[1]: grafana-server.service: Start request repeated too quickly.
Sep 22 14:36:58 cl1grafana systemd[1]: grafana-server.service: Failed with result ‘exit-code’.
Sep 22 14:36:58 cl1grafana systemd[1]: Failed to start Grafana instance.

We can no longer connect. I even tried changing the ini back to how it was when we started, and it still will not start. All we did was edit the ini file
I don;t want to lose all the dashboards and data sources by re-installing.

We are running on Ubuntu Server 22.04 LTS

What am I doing wrong???

Thank you,

welcome to the :grafana: forum, @leonejames1

try increasing the verbosity of the Grafana server logs to debug and note any errors. For printing to console, set the console logs to debug as well.

Have you tried returning the port setting to 3000? Why are you using 443? for TLS? Usually that gets routed through a reverse proxy…

1 Like