Getting gpg: keyserver receive failed: No data when installing k6

Hi, I’m using the instructions for ubuntu on Installation and I’m getting gpg: keyserver receive failed: No data error during install. I tried a different key server hkps:// and got the key file but it seems be wrong as then I got the following error

Err:4 stable InRelease                                    
  The following signatures were invalid: EXPKEYSIG C780D0BDB1A69C86 (key for signing binaries) <>

I also tried the older way:

sudo apt-key adv --keyserver hkp:// --recv-keys $K6_KEY &&\
            echo "deb stable main" | sudo tee /etc/apt/sources.list.d/k6.list &&\
            sudo apt-get update &&\
            sudo apt-get install k6 &&\

but also got no data available. That method I know was working earlier, but now its not…

Hey @wjc,
I’ve just tested locally on a docker instance using a Ubuntu:latest machine and it seems to work for me.

In the past, we have seen similar errors if there was an old key already installed. As reported here from another user.

Unfortunately, the Ubuntu keyserver sometimes is flaky as explained in the thread below, we explain in the comment a potential alternative.

Let me know if it helps.

thanks. the issue seemed to have resolved by itself after a few hours. this happened in our circleci flow and since it uses a new image/container each time, it’s probably not an issue with cached key and most likely the keyserver is just flaky :frowning:

1 Like