Fresh install - https://127.0.0.1:3000 results in "This site can't provide a secure connection"

On a new install of Raspian Buster Desktop, I fillowed the installation instructions and performed the following installation:

sudo apt-get install -y apt-transport-https
sudo apt-get install -y software-properties-common wget
wget -q -O - https://packages.grafana.com/gpg.key | sudo apt-key add -
sudo apt-get update
sudo apt-get install grafana
sudo systemctl daemon-reload
sudo systemctl status grafana-server

When I attempt to connect to graphana via a browser, using Ach - t - t - p - s://127.0.0.1:3000/

I get this display:

This site can’t provide a secure connection127.0.0.1 sent an invalid response.
ERR_SSL_PROTOCOL_ERROR

A look at the log at /var/log/grafana/grafana.log shows:

2020/02/23 06:36:16 [I] Starting Grafana
2020/02/23 06:36:16 [I] Version: master, Commit: NA, Build date: 1969-12-31 19:00:00 -0500 EST
2020/02/23 06:36:16 [I] Configuration Info
Config files:
[0]: /usr/share/grafana/conf/defaults.ini
[1]: /etc/grafana/grafana.ini
Command lines overrides:
[0]: default.paths.data=/var/lib/grafana
[1]: default.paths.logs=/var/log/grafana
Paths:
home: /usr/share/grafana
data: /var/lib/grafana
logs: /var/log/grafana

2020/02/23 06:36:16 [I] Database: sqlite3
2020/02/23 06:36:16 [I] Migrator: Starting DB migration
2020/02/23 06:36:16 [I] Listen: http://0.0.0.0:3000
2020/02/23 06:44:52 [I] Completed 127.0.0.1 - “GET / HTTP/1.1” 302 Found 29 bytes in 9755us
2020/02/23 06:52:43 [I] Completed [::1] - “GET / HTTP/1.1” 302 Found 29 bytes in 3051us
2020/02/23 06:57:06 [I] Completed 127.0.0.1 - “GET / HTTP/1.1” 302 Found 29 bytes in 4022us

So, what am I doing wrong? Thanks for the help.

You haven’t asked Grafana to start with TLS/SSL enabled, so it’s not talking HTTPS but regular HTTP (see also the log you attached where the listening address is specified as http://0.0.0.0:3000). Either do that by setting the server.protocol and server.cert_* options or skip TLS entirely by making using http://127.0.0.1:3000 . If it’s just running locally on your computer, not using TLS is fine.

Thank you for your succinct reply. I will try your recommendations tomorrow and post back here.

Seeing other posts that reported the same problem via an old, unmaintained-by-grafana package that, incredibly, is out in common circulation and which apparently was either installed by my following the grafana website install installations for debian OR I somehow missed a failure of that installation (unlikely) and wound up using a default that arrived with the latest Raspbian Buster Desktop. ANYWAY, it was as simple as:

sudo apt-get remove grafana
sudo apt-get remove grafana-data
sudo apt-get install grafana

The /etc/grafana/grafana.ini file remained from the old install, where I had uncommented:

protocol = http
;http_addr =

The http port to use

http_port = 3000

and voila, it works - http://localhost:3000 gets me to the login and everything else.

I am now running version 6.6.2

Not really sure how having such old packages available in such wide distribution works but, this might require some attention.

Thanks for the help!

The first time round you were using a url starting https not http. I think that may have been the problem.