Error signing manifest: Token invalid

Hello. I am currently running into a error attempting to sign a private data source backend plugin. I am getting the following:

The environment variable $GRAFANA_API_KEY is indeed set prior to running the sign command. I’ve tried numerous keys, and even a service account token which gave a parsing error instead. Suppose they are not supported yet?

I have tried again on a freshly built plugin and get the same error. Running this in Ubuntu on WSL2. Installed versions of pre-reqs:
image

I noticed this thread was left without an answer:

Hoping perhaps someone has some ideas on what to try next.

-Dustin

Welcome Dustin

is the GRAFANA_API_KEY env configure in WSL environment? Where and how did you generate the token

I believe the environment variable is set correctly? See below.


I have tried API keys generated from both my grafana.com cloud account, as well as from the local instance running in Docker. Same error for both.

Solved the issue. I had wondered why I couldn’t see the option for “Plugin Publisher” when creating a new API key, apparently there are two separate API key sections of Grafana Cloud… So, to anyone else who runs into this, ensure you use the link at the top of the cloud home app here:

And then you will see the option for the plugin publisher role as shown below.

Do not use the API Keys under the configuration gear icon in the left menu…

1 Like