Error in Plugin Sign step in Release CI

Hi all, when I try to release my plugin, I am getting an error in the Sign Plugin step in the release.yml workflow.

The Error from the Workflow:

Run yarn sign
yarn run v1.22.19
error Command "sign" not found.
info Visit for documentation about this command.
Error: Process completed with exit code 1.

Sign Plugin Step:

      - name: Sign plugin
        run: yarn sign
          GRAFANA_API_KEY: ${{ secrets.GRAFANA_API_KEY }} # Requires a Grafana API key from

Anyone have any advice on resolving this? Thank you!


Does your code package.json has a “sign” script in the scripts section? When you run yarn [command] yarn first tries to run its own command and then the user-defined ones. sign is a user-defined command and if you don’t have it, it won’t be able to execute it.

I actually was able to fix this, I just forgot to comment here.

Not originally. I explored GitHub - grafana/plugin-tools: Create Grafana plugins with ease. and saw that it should have had this line in package.json, which it didn’t, but worked fine after I added it:

"sign": "npx --yes @grafana/sign-plugin"

I tried to create another starter plugin just now using npx @grafana/create-plugin to see if it has been fixed (I saw the issues in GH), but the line still wasn’t added to plugin.json. I thought that maybe the npx command was out of date, and when I forced version 0.7.0 in the command npx @grafana/create-plugin@0.7.0 now the line was added.

My assumption is that something internally is out of date, when I run npx @grafana/create-plugin, I assume it will run the latest version number, but that wasn’t the case. I’m not sure if that’s something that can be fixed but I wanted to point it out, hopefully it will save others the trouble if/when they encounter this.