Cross-cluster calls are not supported

I’m working with ELK version

"version" : {
    "number" : "8.6.1",
    "build_flavor" : "default",
    "build_type" : "rpm",
    "build_hash" : "180c9830da956993e59e2cd70eb32b5e383ea42c",
    "build_date" : "2023-01-24T21:35:11.506992272Z",
    "build_snapshot" : false,
    "lucene_version" : "9.4.2",
    "minimum_wire_compatibility_version" : "7.17.0",
    "minimum_index_compatibility_version" : "7.0.0"

and Grafana version

$ /usr/sbin/grafana-server -v
Version 9.5.2 (commit: cfcea75916, branch: HEAD)


I get in the Grafana the error below
"Elasticsearch error: Cross-cluster calls are not supported in this context but remote indices were requested: [2023-07-31T00:00:00Z]"

The datasources looks as following:

"id": 259,
"uid": "jFl5w9lVk",
"orgId": 2,
"name": "XXX_XXXXXXX",
"type": "elasticsearch",
"typeLogoUrl": "",
"access": "proxy",
"url": "localhost:9200",
"user": "",
"database": "",
"basicAuth": true,
"basicAuthUser": "xxxxxxx",
"withCredentials": false,
"isDefault": false,
"jsonData": {
"database": "[xxxx_sssss-AAAA_]YYYY.MM.DD",
"esVersion": "8.0.0",
"includeFrozen": false,
"interval": "Daily",
"logLevelField": "",
"logMessageField": "",
"maxConcurrentShardRequests": 1,
"timeField": "TIME",
"timeInterval": "1m",
"tlsAuth": false,
"tlsSkipVerify": false
"secureJsonFields": {
"basicAuthPassword": true
"version": 2,
"readOnly": false

In the dashboard I see the error as in the attached.

No error in the ELK log.

In the Grafana I see only the below error:
logger=grafana.update.checker t=2023-07-31T18:26:57.425465448+03:00 level=error msg="Update check failed" error="failed to get latest.json repo from github .com: Get \"//\": dial tcp: lookup raw .githubusercontent .com on no such host" duration=3.567989ms

Elasticsearch yml:

[root@xxxxxxxx elasticsearch]# cat elasticsearch.yml |grep -v ^# /xxxxxxxxxxxxxx/XXXXXXXXXX
path.logs: /var/log/elasticsearch
http.port: 9200
discovery.type: single-node false false
  enabled: false
  enabled: false
search.max_buckets: 100000
action.destructive_requires_name: false
ingest.geoip.downloader.enabled: false 

[root@xxxxxxxx  elasticsearch]# 

Elasticsearch jvm config file:
[root@xxxxxxxx  elasticsearch]# less jvm.options  |grep -v ^#

[root@xxxxxxxx elasticsearch]#

any hint/help will be great.