X-Requested-With for cross-domain-request

Need to set the headers in Grafana API requests with –
X-requested-With = XMLHttpRequest. How do we go about setting this and rebooting grafana?