[solved] Pushover altering fails

Trying to setup Pushover as contact point.
I configured my API Token and the user key.
The test is failing with the following error:

error="Post \"https://api.pushover.net/1/messages.json\": tls: failed to verify certificate: x509: certificate signed by unknown authority"

I had the same error with configuring email as contact point.
I got this resolved for email with setting the parameter skip_verify = true for SMTP.

Is there any setting parameter like skip_verify also for Pushover notifications?

Thanks, Stefan.

Hi! I would not recommend skipping TLS verification for email or Pushover. It looks like there is a problem with TLS in your system (unrelated to Grafana). Can you run curl https://api.pushover.net? You should get {"status":0} without error.

Hi, curl returns the following:

bash-5.0$ curl https://api.pushover.net
curl: (77) error setting certificate verify locations:
  CAfile: /etc/ssl/certs/ca-certificates.crt
  CApath: /etc/ssl/certs

I am running grafna in a docker container, from inside the container I get the above error message.
Running curl on the docker host it returns without error.

I found a similar problem described here: Link

The resolution was to set a global config parameter:

Setup → Gloabl Settings → [Trusted certificate authorities for SSL] Set: Use system wide CAs from “No” to “Yes”

I searched everywhere in the config parameters but was not able to find it.
I am running grafna V9.5.2.
(I tried both images, Alpine and Ubuntu both not working)
There seems to be a problem within the running containers.

I tried to curl curl https://api.pushover.net from within two other containers (FHEM, iobroker) which are both without error.

Any idea?

Thanks, Stefan.

I solved the issue.
I mapped the /etc/ folder of the container to a local volume without copying the content to local volume. That was the root cause of my problem.