So many issues with this product . I am very frustrated now

As I continues to use this product , I am getting more and more convinced that this is not a Production level product.

Version used : 5.4.3
DB used : Postgres DB

Issues :

  1. Alerts have no sense of triggering. The alert lines comes randomly and nothing relates with the queries written. No examples are given to check how the WHEN condition will work. Nothing makes sense basically.

  2. Notification channel does not accept multiple emails ids even when i add them separated with “;”.

  3. Spark lines are not working at all with this latest version. Not sure if the issue is with Postgres DB or grafana version.

  4. Grafana logs does not reveal much of the information.

Anyone looking into this matter,.please let me know if you need anything for the investigation.

When asking for help (I presume you are asking for help) it is better to say that you can’t get something to work and explain what you are having difficulties with, rather than just stating it doesn’t work. No-one is likely to help if you just say the s/w doesn’t work and don’t actually ask any questions.


Noted. Yesterday’s post was immediately after a meeting that did not go so well. I apologise for my behaviour.

Ok here are the questions :

  1. When i create a Notification channel for the Alerts , I can add more than 1 email id seperated with “;” . But the email does not go to all of them , instead it goes to only first email id. Grafana version = 5.4.3

  2. The Spark Line does not seem to work. It used to work in my previous version. Is it because of the Postgres DB because earlier I used to work in Influx DB. But now swithed to Postgres DB.

I can’t help with (2) but on the Notification Channels page, if you click Send Test do you see multiple Sent popups appear and does it actually send them when you do that.

Pop does not appear. When I click “Send Test” , a success notification appears on the top right corner saying the ‘Test Notification sent’ but the mail only goes to first email id.

I am trying with 2 email ids.
This is how I add them in the channel :;

If you swap the order does it go to the other one?
Are there any unusual characters in the addresses?
Otherwise my only thought is that there may be an unprintable character in there. Completely delete the contents of the field and type them in again to check.

Try separating emails with newline

@clanlaw and @torkel

Did not work. Tried giving the email ids in new line also. I tried swapping and even different email ids. The mails only goes to first email id .

Below are the error logs captured while sending test mail

t=2019-04-05T10:39:56+0800 lvl=eror msg="Failed to send alert notification email" error="gomail: could not send email 1: read tcp> i/o timeout"
t=2019-04-05T10:39:56+0800 lvl=eror msg="failed to send notification" logger=alerting.notifier id=0 error="gomail: could not send email 1: read tcp> i/o timeout"

were you ever able to find a resolution to this issue?