Scientific Notation tickmarks have too many zero digits

Why do I see so many zeros on the y-axis?
This is the correct number of tickmarks, but the number of zeros after the decimal point is clearly at least 5 too many.
Is that a bug? Or is there a way to fix this? Note that my numbers are not always in the 1e-6 range. They could be 1e3.

Try to play with Decimals configuration:

Thanks! I did, obviously. The problem is, when I set the decimals to 4, the smallest number larger than zero that I see is 1e-4. It seems like depending on the value of the decimals, it rounds first, and then it converts to scientific notation. The order should be reversed.

So the automatic settings are not good for showing numbers that are not of order 1 correctly? Seems like a major flaw to me.