Root Certificate path - Grafana on Windows Server


I am using Grafana on Windows server and trying to integrate it with LDAP. However, the root_ca_cert path is generating an error. In my config , I have tried these path:

root_ca_cert = “C:\Program Files\GrafanaLabs\grafana\conf\abc.pem”
The above generates the following error:

t=2021-06-12T02:08:19+1000 lvl=eror msg=“Failed to obtain the LDAP configuration. Please verify the configuration and try again” logger=context userId=1 orgId=1 uname=admin error="Failed to load LDAP config file: Near line 20 (last key parsed ‘servers.root_ca_cert’): invalid escape character ‘P’; only the following escape characters are allowed: \b, \t, \n, \f, \r, \", \\, \uXXXX, and \UXXXXXXXX" remote_addr=[::1]

Another config I tried:

root_ca_cert = “C:\Program Files\GrafanaLabs\grafana\conf\abc.pem”

This one generates the following error.
error=“open C:\Program: The system cannot find the file specified.” remote_addr=[::1]

It seems space character between Program Files is not handled correctly.

Am I entering it correctly?

  • What Grafana version and what operating system are you using?

  • What are you trying to achieve?
    Authentication via LDAP

  • How are you trying to achieve it?

  • What happened?
    error is generated on root_ca_cert path

  • What did you expect to happen?
    System should read the certification without errror

  • Can you copy/paste the configuration(s) that you are having problems with?

  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.

  • Did you follow any online instructions? If so, what is the URL?