Refresh field from greylog

I’m using greylog and querying it with elastic search. I kept getting errors about fields not being numeric. I found that I can add a converter to the extractor that sets it to numeric in greylog. I’ve added it to the fields I needed but I can’t see to get grafana to see the change. Even if I specify a time window that should only contain data with the new setting. Any ideas on how to get them to appear in the field drop down after changing the metric from count?