Receivers not found in type tempo.plain

My intentions is to include telemetry to our .net application and i was testing just building up a system locally following the guide : Instrumenting a .NET web API using OpenTelemetry, Tempo, and Grafana Cloud | Grafana Labs
but after I have everything setup I get this error message from the agent-config.yaml file:
error loading config file /etc/agent-config.yaml: yaml: unmarshal errors:
grafana-agent_1 | line 2: field receivers not found in type tempo.plain
(screenshot with more information)


It’s probably just something in my way of setting all up, I did try to follow the guide step for step and even got the example application from: GitHub - mdisibio/tempo-otel-dotnet-example: Example repo showing how to instrument a .NET 5.0 web api with OpenTelemetry.Net and send logs and traces to Grafana Cloud

Thank you!

1 Like

I got the same problem with grafana-agent version 0.15.0, here is example of my config:

# other Agent settings

tempo:
  receivers:
    jaeger:
      protocols:
         thrift_compact:
  attributes:
    actions:
    - action: upsert
      key: env
      value: prod
  push_config:
    endpoint: tempo-us-central1.grafana.net:443
    basic_auth:
      username: 12345
      # Replace <Grafana API Key> below with an API key that has the "Metrics Publisher" role
      password: <Grafana API Key>

@mattiscedercreutz Did you find any solution?

I found the solution! The problem is that format of config is changed, here is migration guide: agent/migration-guide.md at main · grafana/agent · GitHub