Pushover notifications failing (RESOLVED)

Not sure if this is an issue related to recent grafana updates or something I changed on my system, but my Pushover notifications aren’t going through. When I go to config page for the notification panel and test, I get “Failed to Send Alert Notifications”

I looked in my syslog to see what grafana wrote and I see the following:

logger=alerting.notifier t=2022-03-23T10:04:20.2+0000 lvl=eror msg=“failed to send notification” uid= error=“Post “h||ps://api.pushover.net/1/messages.json”: dial tcp: lookup api.pushover.net on [fe80::2ade:a8ff:feab:9d68%wlan0]:53: dial udp [fe80::2ade:a8ff:feab:9d68%wlan0]:53: connect: invalid argument”

A failed Pushover notification from last week when things were working looks like:

logger=alerting.notifier t=2022-03-12T18:45:48.57+0000 lvl=eror msg=“failed to send notification” uid=berciqRRk error=“Post “h||ps://api.pushover.net/1/messages.json”: dial tcp: lookup api.pushover.net on 8.8.8.8:53: dial udp 8.8.8.8:53: connect: network is unreachable”

Somehow, the api request is trying to use IPv6 addresses now, which I suspect is related to my problem.

Any ideas? (The misformatted http is because the forum won’t let me post more than two urls)

Figured it out. I’m running on a Raspberry Pi 4 Buster Grafana 8.4.4. My /etc/resolv.conf file somehow was using that IPv6 address as its only option. The solution was to go into /etc/dhcpcd.conf and add some regular IPv4 DNS servers with the following line:

static domain_name_servers=192.168.1.1 8.8.8.8 1.1.1.1 208.67.222.222

Then restarted the dhcpc daemon with

sudo service dhcpcd restart

Hopefully in five years, this will help someone searching the entire internet for just the right keywords.