Problem trying to load agent on RPi

Hi I am new to Granafa adn as a start I am trying to load the linux agent onto my RPi. At the third stage I get the message “cannot execute binary file Exc format error”

I have tried to delete the downloaded files on the RPi and start again but I get the same result.

What did I do wrong and how do I fix the problem>

Which Linux agent are you referring?

This is going to sound silly but it is the one in the getting started page. Are you suggesting that I cannot monitor the RPi that is not the same network as my WIN 10 PC?

I don’t know what an RPi is, so I don’t know.

Just generally, if the system you are trying to monitor is in a different network than the PC with Grafana, then how would Grafana see the metrics?

An RPI is a raspberry pie. The RPI is on the same network.

Raspberry pie is cases that I was told about when testing this Installation guide. IIRC, you want to be sure you are using the ARM version of whatever you are working on.

Where did you get the ARM binaries to install on the RPi from?

From the error message “cannot execute binary file Exc format error” it makes
me wonder whether you’re trying to install an x86 package onto and ARM CPU.

Antony.

The binaries were provided by the grafana introduction page. i don’t know if my version of Pi has an ARM processor. i will check.

I will checkout your link Thanks

My RPi has a quad-core A53 (ARMv8) 64-bit processor. For clarity grafana is loaded on my Win10 PC
When I looked at setting up Grafana I came across the ability to monitor a linux system so I started to load the code provided. I think everything went ok (no error messages) until the third instruction. as indicated inmy oiginal question.