PPL and changing the results limit (Opensearch)

I have asked AI, I have read documentation, I have read the plugin main page.

I cannot seem to get the size query to work. How the heck do i get the results limit increased?

I’ve tried:

source=graylog* # this works raw, only returns 200 documents though
source=graylog* size=1000
source=graylog* size 1000
source=graylog* LIMIT 1000
{ "source":graylog* } # doesn't work
{"source":"graylog*"} # doesn't work
{ "source": "graylog*", "size":1000} 
# this is in their plugin docs, and also doesn't work
source=graylog
| size=1000

I’ve tried setting the size value as a header in my connector as well. I’m pulling my hair out

There is a default limit of 500, so you should be getting back at least that many unless the backend you are communicating with has a hard limit set.

Can you try setting the limit lower than 200 and see if you get the expected number of rows back (this will test the parsing of the limit parameter)?

I haven’t tried this yet, but from the codebase it looks like the “size” value may need to be a string.
"size":"1000"

size parsing code