Plugin install error - multiple instances behind load balancer

  • What Grafana version and what operating system are you using?

    Grafana v8.3.4, AWS Fargate (multiple instances behind load balancer)
  • What are you trying to achieve?

    Install plugins from plugin catalog
  • What happened?

The plugin installs, but both a confirmation message and an error are displayed, I suspect it has to do with the multiple instances running behind the load balancer. When running only a single instance, no error is displayed.

I have confirmed that the plugin works on all instances despite the error. The plugin folder is mounted to efs, which all instances share. The database is an aurora mysql. On the network console, this get request fails and I believe is what generates the error

I wouldn’t use EFS, but local filesystem and install plugin via GF_INSTALL_PLUGINS env variable and not via UI.

I think that would be best, and that does fix the issue. But for now i’m using efs because I have some custom plugins which need frequent updates and its much easier to just push them to efs. The only alternative I could figure out was bundling them with docker and re-uploading/deploying each time.

Eventually ill get rid of efs, and the error is really no big deal, was just hoping there was a simple fix out there.

GF_INSTALL_PLUGINS works also with URLs. You just need proper zip package. For example you can download it from the S3 bucket. I’m also lazy, so I download some custom forks from Github directly, e.g.:


I somehow missed that url was an option, I’ll have to try this later. Thanks!

Tried this today and it worked great. The error when installing new plugins from the catalog surprisingly seems to have disappeared as well. Thanks again :smiley: