Odd issue with variables in graphite data source but not influx

Can anyone please help me fix a problem where I can not create variables within my datasource pointing to my graphite data? I can create variables in other datasources and can successfully pull data in panels from the graphite datasource but just can not get it to create variables. The data source is http://localhost:8081 (Apache listening on 8081, set to Server, and I have tried with credentials and without. I keep setting the ‘Version’ field to ‘1.0.x’ and saving but it keeps disappearing.

Ubuntu 18.04.2 LTS
grafana/stable 6.0.1 amd64
graphite-web/bionic,bionic,now 1.0.2+debian-2
python/bionic,now 2.7.15~rc1-1 amd64
apache2/bionic-updates,now 2.4.29-1ubuntu4.5 amd64
libapache2-mod-wsgi/bionic,now 4.5.17-1 amd64

Again, I have added the graphite datasource and I can create panels successfully querying the data. My only problem seems to be related to creating variables using the graphite data source.

I am using apache2 with mod_wsgi. I am getting a big red flag at the top red stating: 'Templating ’ and the following error in /var/log/grafana/grafana.log each time I try to put anything into the Query input field of the create variable page:

t=2019-03-08T21:38:26+0000 lvl=eror msg=“Request Completed” logger=context userId=1 orgId=1 uname=admin method=GET path=/api/datasources/proxy/2/metrics/find status=500 remote_addr=hiddenIP time_ms=599 size=944 referer=“http://hiddenhostname:3000/d/2KiNTdjmz/main-dashboard?editview=templating&orgId=1

sudo cat /etc/grafana/grafana.ini|egrep -v ‘^#|^$|^;’
protocol = http
http_addr = hidden
http_port = 3000
domain = hidden
router_logging = false
enable_gzip = true
log_queries = true
enabled = true
org_name = “Main Org.”
org_role = Viewer
enabled = false
enabled = true
host = hidden:25
from_address = admin@hidden
from_name = hidden
ehlo_identity = hidden
level = error
filters = alerting.extractor:debug
enabled = true
interval_seconds = 10
address =
prefix = prod.grafana.%(instance_name)s.

Apache virtualhost config:
$ sudo cat /etc/apache2/sites-available/apache2-graphite.conf
<VirtualHost *:8081>

WSGIDaemonProcess _graphite processes=5 threads=5 display-name='%{GROUP}' inactivity-timeout=120 user=_graphite group=_graphite
WSGIProcessGroup _graphite
WSGIImportScript /usr/share/graphite-web/graphite.wsgi process-group=_graphite application-group=%{GLOBAL}
WSGIScriptAlias / /usr/share/graphite-web/graphite.wsgi

Alias /static/ /usr/share/graphite-web/static/
<Location "/static/">
	SetHandler None

ErrorLog ${APACHE_LOG_DIR}/graphite-web_error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog ${APACHE_LOG_DIR}/graphite-web_access.log combined

<Directory “/usr/share/graphite-web/”>

# Apache 2.4
Require local

<IfModule !mod_authz_core.c>
# Apache 2.2
Order Deny,Allow
Deny from all
Allow from
Allow from ::1

Thank you in advance for helping me. I have been working on this for days now.

I would check the graphite error logs

Thank you. I had moved on past the graphite logs and I needed to look at them again. I was getting another error that led me to run:

sudo PYTHONPATH=$GRAPHITE_ROOT/webapp /usr/lib/python2.7/dist-packages/django/bin/django-admin.py migrate --settings=graphite.settings --run-syncdb

This was just a problem on my end.