Mssql datasource not work on windows10 WSL

Hi guys:

I’m running grafana v5.1 on win10 WSL ubuntu, then always get an error like ‘Login error: EOF’ when trying to save&test a mssql datasource, any suggestions?

if change the host to an unexists ip,there will be an error like ’
Unable to open tcp connection with host ‘localhost:1433’: dial tcp connect: connection refused’



First, check the Grafana server log after you’ve received your connection error.

Second, are you possibly trying to connect to a MSSQL 2008/2008 R2 version? (show result of select @@Version)

From the GO library we’re using in Grafana to connect to MSSQL:

SQL Server 2008 and 2008 R2 engine cannot handle login records when SSL encryption is not disabled. To fix SQL Server 2008 R2 issue, install SQL Server 2008 R2 Service Pack 2. To fix SQL Server 2008 issue, install Microsoft SQL Server 2008 Service Pack 3 and Cumulative update package 3 for SQL Server 2008 SP3. More information:

If upgrading is not an option for you I suggest you to create a feature request issue for possibility to disable encryption, see



thx for your reply, my SQL Server is 2008 R2, I’ll try as you told

Cool. I’ll update the documentation regarding 2008 (R2).

I created an issue for it to start with.

Documentation have been updated with known issues section.

@mefraimsson,thanks for the updated!


after upgrade to v5.1.3

still get an error like “wsarecv: An existing connection was forcibly closed by the remote host.”
Is this a Known Issue?

But have you upgraded your sql server 2008 r2 to latest service pack?

not yet, there’s not a plan to upgrade product database,any other solution?

I’m afraid not.


Hi, I am using MSSQL 2012, and have same error. What can I do?