Max per row absent for repeat in grafana 7.4.0

I have a very basic panel, with a query (postgres) spitting out a table with 2 columns/1 row, which I want to have repeated horizontally over a variable.
This works nicely, except that I cannot get more than 4 repetition per row:


According to the doc there is a ‘max per row’ setting, which does not seem to exist any more. I cannot find it either in the JSON representation of the dashboard.
What I tried:

  • resize the first iteration (works for height, not for width)
  • resize the latest iteration (no effect)
  • resize and move all to have them on one line (no effect - lost on next reload even after save)
  • all columns of the table are fixed in width - it shows on the screenshot, 50% of each repetition is empty space
  • fit/fill/exact has no effect

How can I set (the equivalent of) “max per row” in grafana 7.4.0?

1 Like

can confirm - same version, same tries, same behavior

@guillaumealliander - it reappears when the panel is actually inside a row

EDIT: I also (instead?) had to, when “horizontal” is selected, switch to “vertical” and back to “horizontal” to make “max per row” appear. HTH

Yes! Thank you! You are right. I had it inside a row for other reasons, and switching from vertical and back made the option appear. Not sure which one was the trigger, but with both together it works.
Thanks again!