Latest K6 version won't install

I click on the msi and nothing happens.
I tried running the file from an elevated command prompt in windows and I get the message “access is denied”.
Has anyone run into this?


that’s strange, it should install fine by just double-clicking on the installer. I tested the v0.27.1 MSI package on Windows 10 Home 1903, and while the UAC prompt took a few seconds to appear, it did pop up and the installation finished successfully. Make sure you’re using this same version and package.

Some questions to see if we can track this down:

  1. Which Windows version are you using? (Home/Pro, version and build number; running winver will show you this)

  2. Does this happen only with the latest version? Do older versions like v0.26.2 install fine?

  3. Try checking “Unblock” in the file’s properties:

    Annotation 2020-07-31 153725

    I actually didn’t have to do this, but maybe it’s needed in your environment.

  4. Did you change any UAC settings? Make sure that it’s on the default “Notify me only when programs try to make changes to my computer” or higher setting. Actually, you might try disabling it before installing k6 and turning it back on, but I wouldn’t recommend messing with it. :slight_smile:

  5. Are you running any antivirus software (e.g. Microsoft Defender)? Confirm there are no false positive alerts on it that might be blocking the installation.

  6. Check for any relevant errors in the Event Viewer (Win+R, eventvwr).

If all else fails, you can always use the binary in the * package from the releases page.

I tried on several packages, including the ones you provided links to, and I got the same behavior.
According to Winver, I’m running Windows 10 Pro version 2004.
Actually, clicking “unblock” in file properties seems to have done the trick.