K6 installation on OpenShift - PODs error

Hi All,

I have U-20 machine on which i have deployed openshift & it is up and running. Openshift is running on cluster mode. Further i have taken K6 image from docker(grafana/K6) which i am trying to deploy on openshift cluster.

I am trying to create new app with the below command
oc new-app --name=k6 --docker-image=grafana/k6:latest

But the node always goes in CrashLoopBack. Initial GCP VM was of 6 core and 18GB.Found one of the solution of Pods status being Crashloopback was due to unavailability of hardware. Hence increased H/w to 12 core 48 GB memory. Still the issue is not resolve and the pods are still in crashloopback . Any help will really help in solving the issue.
I am running the setup with root user.
root@docker:/home/rajnish/docker/openshift-origin-client-tools-v3.11.0-0cbc58b-linux-64bit# oc get pods
k6-1-deploy 1/1 Running 0 2m
k6-1-l79k5 0/1 CrashLoopBackOff 4 2m
Do suggest in case of any additional info required.


Hi @rajnishghose

Welcome to the community forum :wave:

Have you tried running k6 with the operator? I would recommend to run k6 that way if you can.

For your current situation, have you checked the pod resource limits (running this way you are probably using defaults) and the resources unused in the nodes?Are you still seeing the same error increasing node resources? The issue is probably on the kubernetes/oc side, more than k6, and without access to your environment it is difficult to help.


Hi Imma,

Getting the same error even after increasing the resources.
I have deployed Openshift on U-20 machine over GCP.


Hi Rajnish,

Without seeing the logs and accessing your platform, it might be difficult to help. This seems more in the realm of Kubernetes than k6, and you might be better off for this in a Kubernetes or OpenShift forum.

Have you tried using the k6-operator? This should simplify running k6 in k8s and we can better help if you run with the operator.