K6 Cloud Plugin not support Grafana

H Team,

When I try to install the K6 Cloud App plugin on Grafana it wont to allow us to install it. guide on me.

It says "You do not have permission to INSTALL this plugin.

I tried both Grafana-oss and Grafana on docker compose.

Hello. This looks like it might be some kind of permissions problem on the Grafana side rather than something specific to this plugin. Does the conversation here help?

Hi @tom,

I changed the permission to the folders to 104 and 472


but still, I’m not able to install the plugins.

Could this be because you are logging on as an anonymous user? I wouldn’t be surprised if anonymous users aren’t given the necessary permissions to install plugins.

A colleague of mine has tried the following docker-compose.yml and it worked. Comparing the two makes me suspect that it may be because of the environment variables + anonymous login:

version: '3'

    image: grafana/grafana-oss:latest
      - "3000:3000"
      - ./provisioning:/etc/grafana/provisioning

The default login is admin/admin (you’ll be asked to change the password upon first login).

1 Like

Thanks, @Tom . Once we disable the environment variables it allows us to install the plugin manually, but it’s better to install through docker-compose, but still, it’s not working. Guide me if you know the options.


Sorry for the delay.

What exactly isn’t working?

All I can say is that there’s a difference between the docker-compose I linked and the one in your screenshot, namely the volume ./grafana-provisioning/:/etc/grafana/provisioning might need to be ./provisioning:/etc/grafana/provisioning. Without knowing what errors you’re seeing I can’t say for sure though.