Issue with adding MySQL Database

When adding a data source for MySQL to Grafana and hitting “Save & Test” I get the error, "
commands out of sync. Did you run multiple statements at once?" The database is just a simple one with two tables in it with four columns each.

Any help is appreciated.

I also get this error.
I get the message when I try to test the connection - maybe some commands are issued too fast or there is an error in the setup script?

What have you got for the Host in the data source?

I have installed Grafana on my workstation (windows) and try to connect to MySQL server at my Synology box.
my Host is: (port is different from the 3306 standard, but that’s the setting on the NAS)
user and password should be good - I’m using the same user to insert into the DB. (only select and insert enabled for that user)

Is that from the same workstation?

1 Like

well, technically no - the webuser is used on a php page to insert into the DB.

That led me to check the host allowed for the user. it was ‘localhost’

Following the suggestions here:

Remember to run all 3 commands including the flush command

NOW the DB connection is all good :slight_smile:
So an error on my part - The user was only allowed on the same machine.
However the error provided is hard to decipher. This thread came up as one of the only ones when searching. This can hopefully help somebody else.

Thanks for the help @clanlaw!

I agree, you would have to talk to the MySQL developers to get that improved though.