Is it possible to disable the legacy gRPC endpoint on the agent?

I had a weird issue where my grafana-agent was stuck in a systemd restart loop because of a port conflict. In this case it happened to be because our own application was configured to grab a random port and grabbed 55680, which also happens to be the default port for the legacy endpoint.

ts=2021-04-05T14:30:42Z level=info msg="Setting up a second GRPC listener on legacy endpoint 0.0.0.0:55680" component=tempo tempo_config=local component_kind=receiver component_type=otlp component_name=otlp
ts=2021-04-05T14:30:42Z level=info msg="Starting GRPC server on endpoint 0.0.0.0:55680" component=tempo tempo_config=local component_kind=receiver component_type=otlp component_name=otlp

I searched through the docs but haven’t found a way to either overwrite the legacy gRPC port configuration or simply disable this endpoint, am I missing something?