HTTP Error Bad Gateway - Where is the "access" key under 'HTTP' when setting up for prometheus?

I am trying to set up prometheus + grafana and I’m getting an error of HTTP Error Bad Gateway:

I’ve found some sources saying that setting the ‘access’ key for ‘http’ could help;
but how come I don’t have the ‘access’ key in my webUI??