Grafana.ini not able to edit


I need to edit grafana.ini to enable authentication with Auth0. But i am not able to edit this file as i am only getting an error “read-only file” . I also tried to copy the updated configuration file but sill getting an error:

root@prometheus-grafana-8565cd787b-x275z:/etc/grafana# cp grafana.ini_backup grafana.ini
cp: cannot create regular file ‘grafana.ini’: Read-only file system

Can somebody please help.

“Read-only file system” is:

a) potentially a big problem

b) not a Grafana problem

c) something you should investigate and resolve with urgency (see (a) above.


  1. this is not the best mailing list / forum for you to get with such a
    problem, if you need it - this is a more basic Linux / sysadmin question

  2. You should find out why the file system has become read-only - look in your
    syslog or dmesg for any information about a disk error leading to the file
    system getting ounted read0only (if you’re not familiar with syslog and dmesg,
    see (1) above)

  3. The solution will probably involve a reboot, but I do not recommend simply
    doing this before you’ve found out why the system became read-only in the first
    place, just in case you have a failing disk and the problem will only recur
    some time after the reboot, possibly with bigger consequences

  4. Above all, make sure you have working backups of your data and configuration
    from this machine, although I hope it’s not necessary to say that sort of
    thing these days - everyone should be doing backups as a matter of course :slight_smile:

Hope that helps,


Hi @pooh

Thanks for the reply. I have installed grafana using helm chart on kubernetes. Grafana is working fine. I am not able to make any changes in this file only.

Are you saying that you can make changes to other files on the same file system?

The error you reported was “read-only file system”, which would affect far more
than just one file.

You also showed that you were not able to create a file in the file system
(although the command you showed was the wrong way round - I hope this was a
typo and not what you really tried to do - the copy command is followed by the
source file and then the destination file).

On the other hand, I know nothing about Kubernetes or Helm Chart, so it’s
possible that they may be doing something weird with symlinks or overlay file
systems, which could affect your ability to do normal things like this.

Either someone here who also uses Kubernetes might be able to help, or you
might get assistance on a Kubernetes list / forum.