OS: Debian 13 Trixie
Grafana: version 13.2.0
Postgresql: PostgreSQL 17.11 (Debian 17.11-0+deb13u1)
Grafana failed to start after upgrade to 13.2 from 13.1.1.
2026-08-20T07:33:47.775444-04:00 raspberry05 systemd[1]: Started grafana-server.service - Grafana instance.
2026-08-20T07:33:48.675592-04:00 raspberry05 grafana[115709]: Error: ✗ pq: duplicate key value violates unique constraint "role_pkey" (23505)
2026-08-20T07:33:48.681000-04:00 raspberry05 systemd[1]: grafana-server.service: Main process exited, code=exited, status=1/FAILURE
2026-08-20T07:33:48.682598-04:00 raspberry05 systemd[1]: grafana-server.service: Failed with result 'exit-code'.
2026-08-20T07:33:48.683345-04:00 raspberry05 systemd[1]: grafana-server.service: Consumed 1.000s CPU time.
2026-08-20T07:33:48.906476-04:00 raspberry05 systemd[1]: grafana-server.service: Scheduled restart job, restart counter is at 1.
Had to update the sequence using.
SELECT setval(pg_get_serial_sequence('role', 'id'), COALESCE(MAX(id), 1)) FROM role;
Restarted Grafana. So far everything seems to be working.