Followed all tips on the forum but still no iframe login

Grafana is running in my local network on a Raspberry Pi and I have set a port-forward to port 3000 ( so that Grafana can be accessed outside my home network. That works well and I can log in without any problems.

Now I have a Wordpress website hosted as usual with a hostingprovider and it works properly. When I want to use a Grafana chart in an iframe on that site, I see the Grafana login screen, but login is not possible. For a short while the logged in message pops up but immediately after that I have to log in again. And so on.

I have set “allow_embedding = true” and “cookie_samesite = none” in grafana.ini and removed the semicolons. It doesn’t matter if I use lax, none or disabled behind cookie_samesite.

Unfortunately I cannot continue with the website because I have no idea how to fix this. Can anyone help me?

Double check if your mentioned settings are really applied in - users quite often mix config files/options, so then they may think that’s configured, but actually it’s not.

Also browser console is your good friend for debugging. Also your full Grafana config will be useful. You may messing with with domain, https configs and they may apply generated cookie.

Thanks for helping! The settings rechecked but they were okay. Looked at your advice with a browser console and I noticed that everything works fine with Firefox on Win10 and also with Android Chrome. On Chrome Win10 the problem remains so it seems browser related. Now find out why, but it will not caused by Grafana.

Please also check Chrome and Edge do not accept correct login data, Firefox works - #2 by grans for a follow-up.