Fields specified in Bar Gauge Query are ignored when selecting Value options/Fields/All Fields

  • What Grafana version and what operating system are you using? 8.0.4 (81fef5b4b4)

  • What are you trying to achieve? Define Field Types (Time and Number) for CSV Datasource for a Bar Gauge Panel

  • How are you trying to achieve it? List the specific fields within the Query definition and then set Value options/Fields equal to All Fields

  • What happened? The Bar Gauge Panel displays all Fields, rather than just the 2 Columns to Include

  • What did you expect to happen? The Query filter would be applied/maintained before applying Value options

  • Can you copy/paste the configuration(s) that you are having problems with? I can only post partial data here from the Query Inspector. But the Schema does not match the response Fields)
    {
    “request”: {
    “url”: “api/ds/query”,
    “method”: “POST”,
    “data”: {
    “queries”: [
    {
    “decimalSeparator”: “.”,
    “delimiter”: “,”,
    “header”: true,
    “ignoreUnknown”: false,
    “refId”: “A”,
    “schema”: [
    {
    “name”: “LastUpdate”,
    “type”: “time”
    },
    {
    “name”: “Results”,
    “type”: “number”
    }
    ],
    “skipRows”: 0,
    “datasource”: “GetAllProjectsData - CSV”,
    “path”: “”,
    “queryParams”: “”,
    “body”: “”,
    “datasourceId”: 1,
    “intervalMs”: 20000,
    “maxDataPoints”: 1102
    }
    ],
    “range”: {
    “from”: “2021-07-06T10:37:42.213Z”,
    “to”: “2021-07-06T16:37:42.214Z”,
    “raw”: {
    “from”: “now-6h”,
    “to”: “now”
    }
    },
    “from”: “1625567862213”,
    “to”: “1625589462214”
    },
    “hideFromInspector”: false
    },
    “response”: {
    “results”: {
    “A”: {
    “frames”: [
    {
    “schema”: {
    “name”: “GetAllProjectsDataCsv”,
    “refId”: “A”,
    “fields”: [
    {
    “name”: “Product”,
    “type”: “string”,
    “typeInfo”: {
    “frame”: “string”,
    “nullable”: true
    }
    },
    {
    “name”: " Status",
    “type”: “string”,
    “typeInfo”: {
    “frame”: “string”,
    “nullable”: true
    }
    },

  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were. No Errors that I’m aware of

  • Did you follow any online instructions? If so, what is the URL?

To be fair I’m not sure if there is a better way to attempt to do this than including Fields within the Query definition (and then selection the Value option ‘All Fields’. As far as I can tell the CSV datasource defines all Fields as Datatype String

This topic was automatically closed after 365 days. New replies are no longer allowed.