Error when trying to add new link to panel

When I try to add link to panel I get this message:

An unexpected error happened

Error: Point.createProperties only accepts objects or points, but you passed it: 00

Following other info which I’m not able to add to this msg

My installation is Grafana 7.5.6 on Ubuntu 20.04

This happens on any panel or dashboard.

Thanks for any help on this issue!

Marco

Can you clarify what you mean here? What kind of panel do you have, and what do you mean by “link”? A data link? Maybe a screenshot would help. Ideally you should use the template format

Hi Svet,
thank you for you reply.

Sorry to not explaining me in a clear way.

I’ve started playing with grafana since version 6. Installation and updates were done using apt on ubuntu. Some days ago I tried to add a link to a panel using add link function under display section, as shown on next picture:

It doesn’t matter which panel I use, “add link” always fails.

First part of the error message is:

Error: Point.createProperties only accepts objects or points, but you passed it: 40

then debug data follows. I can’t cut and paste the message, post form won’t accept it. So here is a screen dump:

Installed version:

Grafana v7.5.6 (5fdad5bfe4) on Ubuntu 20.04

Thanks @marchino2000 for the info! I see now. That is indeed very odd! I take it that you get this error as soon as you click the “add link” button?

I’m afraid this doesn’t ring a bell, but maybe others on here have ideas.

If it’s easy for you to do, it may be worth installing a different version of grafana and seeing if it still happens there. Basically trying to isolate the cause of the issue.

Don’t know if the stacktrace from the browser console could help:

The error comes out from every panel and dashboard, even new ones. Existing links are working and they don’t rise any error when edited. I tried both Chrome and Firefox, same result.
I can’t understand if this bad value is coming from the backend or not.

Regards

Hi everybody,
at least we found that the issue is triggered if browser is configured to use our internal http proxy, privoxy. If disabled (i.e. direct browser connection to Grafana), everything works like a charm.
Sorry for wasting your time.

Regards