Error signing manifest: Request failed with status code 500

I’m trying to sign a private plugin, something is failing but I cannot find what it is, any idea?

npx @grafana/toolkit plugin:sign --rootUrls http://localhost:3001
Building manifest…
Signing manifest…
Error: Error signing manifest: Request failed with status code 500
at /home/lperf/.npm/_npx/12964/lib/node_modules/@grafana/toolkit/src/plugins/manifest.js:168:27
at step (/home/lperf/.npm/_npx/12964/lib/node_modules/@grafana/toolkit/node_modules/tslib/tslib.js:143:27)
at Object.throw (/home/lperf/.npm/_npx/12964/lib/node_modules/@grafana/toolkit/node_modules/tslib/tslib.js:124:57)
at rejected (/home/lperf/.npm/_npx/12964/lib/node_modules/@grafana/toolkit/node_modules/tslib/tslib.js:115:69)
at processTicksAndRejections (internal/process/task_queues.js:95:5)

grep ^root_url /etc/grafana/grafana.ini
root_url = http://localhost:3001

the first part of the id in the src/plugin.json matches the organization name on my grafana cloud account
And I created the key with the pluginpubliser role.

Is there any flag that I could use to try to understand the issue?


A status code of 500 would indicate that the issue is with the Grafana API rather than in your plugin. Are you still experiencing this, or did you manage to sign the plugin eventually?

I haven’t signed the plugin yet. I’ve tried in a number of systems and it happens all the time.
I tried signing the Simple panel, without modifying anything but it didn’t work either.

Is there anything I could enable to try to debug this issue?

Unfortunately, there’s no debug logging available. I’ve forwarded the feedback to the team.

We’ve had some related issues that will be fixed in the next version, though I’m not sure if that’s what you’re seeing.

I would try and sign the plugin using the canary release and see if the issue is still there.