Elasticsearch Time Field Name

I’m trying to add an elasticsearch datasource but can’t get past the Time field name. I tried @timestamp but it doesn’t work. The only time-related field I see in my index is creation_date, which I also tried as @creation_date for time field name but it fails. The error is “no date field named @timestamp found”. What am I missing?

Remove the at symbol, if your field name does not contain it do not use it, the at symbol is not speciall, it just commonly named with at symbol prefix

@sbanik you can use the field whose type is date in elastic search for this mapping. you should use the exact same field name as in the index type.

What if my column is not date type?
Will string type in date format work too???

1 Like

Does this problem has been solved? I have the same question.

i met with the same issue. after reading grafana doc on elasticsearch datasource, realized that you have to set the index name correctly, you have to enter [index-name]-YYYY.MM.DD in index name field if your index pattern is daily and everyday indexes are like this index-name-2019.10.24.
After setting the index correctly, it is not complaining @timestamp doesn’t exist anymore.