(Docker) Setup of Container?

still not running my grafana. I have a Syn DS1621+ with Docker, image grafana.latest.
Setup Volume, Port, Variables
Ports - how do I tell Grafana to run on like iobroker does?

other settings

Just to understand, are you trying to set the IP address of the Docker container that Grafana will run in? That is entirely up to the settings of the (Docker) network environment you’re running in, and not something that Grafana has control over.

Moreover, I don’t think that setting the IP address of the Grafana container to the same IP address that another container already has is possible (the whole point of IP addresses is that they’re unique on your network).

Can you tell us a bit more about what you’re trying to achieve?

Hi, just want to run Grafana in Docker of Synology, not more.
Still trying to understand how things working.
Could you tell me how to setup grafana?
should work with influxdb to iobroker.

I think it’s worth getting familiar with how things are normally set up in Docker, at least at a high level:

  • Each container will have a separate IP address on the Docker subnet
  • The containers should be able to see each other
  • Docker can map specific ports from different containers onto the host (the “local port” in your config), so these are accessible to you

For the Grafana container, you probably want to map TCP port 3000 on the container onto local port 3000 (not port 1) and then access it over http://:3000. Have you managed to get that far?

Yes, does not work. I tried really a lot, and my infos about docker is already more than the first post.

Actually I try to activate the container grafana/grafana:latest (image downloaded)
3000 - 3000 - tcp

after it is installed and running, I try to connect via IP:3000 and nothing ?

right now, it is startet - stopped - restarted… all the time… ?? by docker

Ok that means there’s an error somewhere and Grafana fails to start. Can you pull up the logs in Docker? (sorry I’m not familiar with the Synology setup/UI)

One thing to potentially try is to remove all the environment variables, and get Grafana running with a default configuration. You shouldn’t need any of those to be set for it to run.

I am trying to delete all and get back to start, but deleting the container and files on the nas does not solve a problem with the network. Still there are staying the the network configs I have done before??

Thanks for the update. Hopefully you’re able to resolve that.

OK, I solved the problems I have, now I have a new setup of docker.
How do I exactly get grafana inside docker to run, not that I do the same mistake again.

Can you try running it without any options (no environment variables set), with just a mapping on port 3000? That should hopefully run successfully. Once you’ve confirmed that it does, you can start adding the options you actually need.