dashboard init failed after upgrade to 8.0.0


After upgrade to 8.0.0 one dashboard show “init failed”

How to debug why?


1 Like

I would check the Grafana logs for more detailed information, or your browser’s dev tools. It will be very hard to answer this without more information.

I would suggest resubmitting and using the provided template


i got this after importing old dashboard json. and no errors in log files. how i can get info why init is failed?

Problem was with missing grafana-singlestat-panel plugin. No errors about that was displayed. Plugin marked as included with Grafana, but its not. Grafana was installed from Docker Hub

Same issue here. after delete the singlestat panel, it works again.


I am also having the same issue. Could you please explain more about how did you get rid of this?

upgrade to 8.0.1 fixing issue


This is how, I got it worked:

  • sudo grafana-cli plugins install grafana-singlestat-panel
  • sudo systemctl restart grafana-server.service
  • sudo systemctl restart grafana.service

This fixed it for me. You cannot download and install the singlestat plugin manually so upgrading to 8.0.1 is the only option if you are using Docker