Chunks & indexes are not getting deleted from cassandra instance even after retention period

Below is my schema config for loki

  schemaConfig:
    configs:
      - from: 2023-09-24
        index:
          period: 24h
          prefix: loki_index_
        chunks:
          prefix: chunk
          period: 24h
        object_store: cassandra
        schema: v11
        store: cassandra 

Below is my storage_config

  storageConfig:
    cassandra:
      addresses: cassandra-test.custom.domain.com
      keyspace: new_test
      SSL: true
      CA_path: /etc/ca/combined/privateKey
      tls_cert_path: /etc/tls/combined/tls.crt
      tls_key_path: /etc/tls/combined/tls.key 

Below is few table manager config values

tableManager:
  enabled: true
  retention_deletes_enabled: true
  retention_period: 48h 

Now chunks and indexes are getting created in cassandra instance but those are not getting deleted after retention period.

Below are chunks & indexes from cassandra storage

  table_name
------------------
       chunk19624
       chunk19625
       chunk19626
 loki_index_19624
 loki_index_19625
 loki_index_19626 

Below are my table-manager pod logs

level=info ts=2023-09-25T12:32:42.79848395Z caller=main.go:103 msg="Starting Loki" version="(version=2.7.0, branch=HEAD, revision=1b627d880)"
level=info ts=2023-09-25T12:32:42.799667108Z caller=server.go:323 http=[::]:3100 grpc=[::]:9095 msg="server listening on addresses"
level=info ts=2023-09-25T12:32:42.800032521Z caller=modules.go:1102 msg="failed to initialize usage report" err="Unrecognized storage client cassandra, choose one of: aws, s3, gcs, azure, filesystem"
level=info ts=2023-09-25T12:32:42.91287651Z caller=events.go:247 module=gocql client=table-manager msg=Session.handleNodeUp ip=12.34.56.789 port=9042
level=info ts=2023-09-25T12:32:43.938978642Z caller=module_service.go:82 msg=initialising module=server
level=info ts=2023-09-25T12:32:43.939049172Z caller=module_service.go:82 msg=initialising module=table-manager
level=info ts=2023-09-25T12:32:43.939249355Z caller=loki.go:399 msg="Loki started" 

Is there any config i’m missing to add ??

Try using compactor instead of table manager, and make sure table manager is disabled.