Change max value for a specific field

I have the following Loki query that shows me the error rate for my containers:

(sum(rate({namespace="namespace", cluster="cluster", level="error"}[1m])) by (cluster, container, level, namespace))>0.5

I’m using the above query with a visualization of type “Stat”. Other settings for this dashboard are:

  • Query type is set to Instant.
  • Under “value options” I set it to calculate All values.

At this point I each container gets the title of cluster, container, level, namespace. I used “Transform” to hide those fields:

Now I’m trying to change the max value for a specific container, but I can’t figure out how to do it. I tried the regular override, but the container names doesn’t appear there:

Any help would be appreicated.

These are field overrides not value overrides. If the container field contains multiple values, then you could try the “rows to fields” transformation to try and set the max per field.

Hello,

what do you want to change it to?

The query I use fetches multiple containers. I have set a max value for all of them, but a specific container needs to have a higher max value.

Okay, can you provide us with some log messages?

Sorry, I’m not sure which logs to provide as there is no error. I’m just trying to change the max value. I’ll try to provide more context:

I’m running the following query:

(sum(rate({namespace="namespace", cluster="prod", level="error"}[1m])) by (cluster, container, level, namespace))>0.5

The result of this query are a bunch of containers and the amount of errors the produce. To avoid showing the amount of errors over a timerange, I changed the query to be of type Instant:

I also set it to calculate “all values”:

With this setup, I want to change the max value of one of my containers, but when I try to override, I don’t even see my container name in the options:

I’m clearly misunderstanding something :slight_smile: