Bug with Panel & Row repeats - SingleStat

I’m using the following query to Prometheus … mongodb_mongod_replset_my_state{}

{
  "xhrStatus": "complete",
  "request": {
"method": "GET",
"url": "/api/v1/query?query=mongodb_mongod_replset_my_state%7B%7D&time=1566234819"
  },
  "response": {
"status": "success",
"data": {
  "resultType": "vector",
  "result": [
    {
      "metric": {
        "__name__": "mongodb_mongod_replset_my_state",
        "consul_service_id": "Mongos",
        "instance": "system-wc-01p..system.com",
        "job": "Mongos",
        "notify_email": "true",
        "notify_oiv": "false",
        "notify_slack": "true",
        "oiv_desk": "hsd",
        "set": "vdm_mongo"
      },
      "value": [
        1566234819,
        "1"
      ],
      "values": [
        [
          1566234819,
          "1"
        ]
      ]
    },
    {
      "metric": {
        "__name__": "mongodb_mongod_replset_my_state",
        "consul_service_id": "Mongos",
        "instance": "system-wc-02p..system.com",
        "job": "Mongos",
        "notify_email": "true",
        "notify_oiv": "false",
        "notify_slack": "true",
        "oiv_desk": "hsd",
        "set": "vdm_mongo"
      },
      "value": [
        1566234819,
        "2"
      ],
      "values": [
        [
          1566234819,
          "2"
        ]
      ]
    },
    {
      "metric": {
        "__name__": "mongodb_mongod_replset_my_state",
        "consul_service_id": "Mongos",
        "instance": "system-wc-03p..system.com",
        "job": "Mongos",
        "notify_email": "true",
        "notify_oiv": "false",
        "notify_slack": "true",
        "oiv_desk": "hsd",
        "set": "vdm_mongo"
      },
      "value": [
        1566234819,
        "2"
      ],
      "values": [
        [
          1566234819,
          "2"
        ]
      ]
    }
  ]
}
  }
}

This returns the desired results per above in the query with my three mongo servers all having 1, 2, 2 values. I’m then using functionality here: https://github.com/grafana/grafana/issues/1888 to get this value by host (single stat). BUT when I finally go back to my dashboard all THREE of my values are 1,1,1 even though the hosts prefix I have on each one is specific to the right hosts…

So whats wrong with the above here?

What is your query? The query you pasted as no label filters for host. Where are you using your template variable?

mongodb_mongod_replset_my_state{}

above is my only query with the $host being set as the title which repeats find on the dashbaord, its the just the value doesn’t change per host for some reason…

hello - any guidance here?