Bad Gateway Errors

CMD screenshot of me accessing influxdb using CLI interface in the Windows Command Line Prompt

access_influxdb_using_cli

Are you able to access the database from a command line running inside the grafana container? I don’t use docker with grafana but I do know that it is necessary to allow the container access to localhost for that to work. Have you tried using the ip address of the machine rather than localhost? Also check that works from the command line in case influx is only accessible via localhost.

[Edit] If you don’t need to enter a user/pwd to access the db in the command line they you should not have basic auth enabled or provide a user/pwd

1 Like

I replaced “localhost” with my IP address and it worked. Maybe that could work for you too.

I have tried to reply on the forum, but because i’m a new user i cannot. Yes thankyou i replaced the localhost with IP address and it worked right away.

Maybe you can reply on the forum?

Regards

Glad that it worked.

Thank you.