Able to connect to loki-query-3-b2bb61c2 over TCP but UDP probes failed, network may be misconfigured”

Describe the bug
Loki cluster has been deployed in kubernetes.
But now the data is not collected rightly. There is errors just as follows:

code:NoSuchKey,get object failed,http://xxx.1xx.xxx.xxx/api/v1/obj/netflow-8-207/fake/e34de9eda3383a6e:183de527f24:183de529614:7386acd6/, the file object is not exist

when I read the log of loki write , there are errors just as follows:

UTC ignored, reason: ‘Per stream rate limit exceeded (limit: 3MB/sec) while attempting to ingest for stream ‘{job="netflow"}’ totaling 782B, consider splitting a stream via additional labels or contact your Loki administrator to see if the limit can be increased’ for stream: {job="netflow"},\ntotal ignored: 118 out of 1047" msg=gRPC
ts=2022-10-16T01:06:40.633226247Z caller=memberlist_logger.go:74 level=warn msg=“Was able to connect to loki-query-3-b2bb61c2 over TCP but UDP probes failed, network may be misconfigured”

and another error message :

caller=tcp_transport.go:428 component=“memberlist TCPTransport” msg=“WriteTo failed” addr=100.79.60.220:7946 err=“dial tcp 100.79.60.220:7946: i/o timeout”

I have already modified the limit config of loki write,just as follow:
-------- the limit content of loki write ------------
limits_config:
enforce_metric_name: false
reject_old_samples: true
reject_old_samples_max_age: 168h
ingestion_rate_mb: 128
ingestion_burst_size_mb: 256
max_entries_limit_per_query: 50000
split_queries_by_interval: 1m
max_query_parallelism: 100

------------ the memberlist content of loki -------------
memberlist:
join_members: [“loki-write”,“loki-query”,“loki-frontend”]
bind_port: 7946
bind_addr: [‘0.0.0.0’]
# You can use a headless k8s service for all distributor,
# ingester and querier components.
#join_members:
#- memberlist.netflow-8-135.svc.cluster.local:7946

  max_join_backoff: 1m
  max_join_retries: 10
  min_join_backoff: 1s

Can anyone help me to solve this problem?Thanks very much.

loki distributor and ingester is in one config file, and just run as one pod, the config is as follows:
distributor:
ring:
kvstore:
store: memberlist

ingester:
  wal:
    enabled: true
    dir: /tmp/wal
  lifecycler:
    ring:
      replication_factor: 1
      kvstore:
        store: memberlist
    final_sleep: 0s
  chunk_idle_period: 12h
  max_chunk_age: 12h
  chunk_retain_period: 1m
  max_transfer_retries: 0
  chunk_target_size: 4194304
  chunk_encoding: snappy

memberlist:
  join_members: ["loki-write","loki-query","loki-frontend"]   
  bind_port: 7946
  bind_addr: ['0.0.0.0']
  # You can use a headless k8s service for all distributor,
  # ingester and querier components.
  #join_members:
  #- memberlist.netflow-8-135.svc.cluster.local:7946
  
  max_join_backoff: 1m
  max_join_retries: 10
  min_join_backoff: 1s

and the query is runing in one pod, the config is as follows:
querier:
query_timeout: 5m
max_concurrent: 30
engine:
timeout: 5m

I have not add any value about ring in the section of query above.
Is there something wrong?
Thanks very much.