A problem with grafana reverted changes

Okay so to start off I had a grafana project, that i wanted to translate to Polish. I set up grafana on a VPS server with ubuntu 20.04 LTS. We used grafana-translate git project, but it didn’t translate much, so we started to translate manually.(i know, thats a lot of work)

We left grafana running on a server and started to translate the files on our computers, and pushing them to our github. We made a mistake, by not checking the changes every update, but we just pulled all the commits at once to the server.

We got theese errors:

Error: Minified React error #185; visit https://reactjs.org/docs/error-decoder.html?invariant=185 for the full message or use the non-minified dev environment for full errors and additional helpful warnings.

at Mt (http://diagnostics.domain.pl/public/build/6518.7bf7079e5ffd2b9b4bd3.js:7302:18)
at Ft (http://diagnostics.domain.pl/public/build/6518.7bf7079e5ffd2b9b4bd3.js:7302:839)
at n (http://diagnostics.domain.pl/public/build/633.7bf7079e5ffd2b9b4bd3.js:2:942012)
at ce (http://diagnostics.domain.pl/public/build/6518.7bf7079e5ffd2b9b4bd3.js:4324:193)
at t (http://diagnostics.domain.pl/public/build/633.7bf7079e5ffd2b9b4bd3.js:2:989568)
at t (http://diagnostics.domain.pl/public/build/633.7bf7079e5ffd2b9b4bd3.js:2:991589)
at main
at t (http://diagnostics.domain.pl/public/build/633.7bf7079e5ffd2b9b4bd3.js:2:986186)
at div
at qs (http://diagnostics.domain.pl/public/build/6518.7bf7079e5ffd2b9b4bd3.js:2156:1022)
at d (http://diagnostics.domain.pl/public/build/6518.7bf7079e5ffd2b9b4bd3.js:4770:26194)
at Sl (http://diagnostics.domain.pl/public/build/6518.7bf7079e5ffd2b9b4bd3.js:2868:458)
at kl (http://diagnostics.domain.pl/public/build/6518.7bf7079e5ffd2b9b4bd3.js:2868:1006)
at l (http://diagnostics.domain.pl/public/build/633.7bf7079e5ffd2b9b4bd3.js:2:969088)
at $e (http://diagnostics.domain.pl/public/build/6518.7bf7079e5ffd2b9b4bd3.js:4337:436)

From seeing theese we just thought, that we might be able to change theese two files via FTP and get the older version of theese to running. We were terribly wrong. We were getting the same error on and on. The page was reloading so fast, we couldn’t even actually read it.

we ended up nuking this installation and tried to revert the changes. We literally reverted all of the commits, to the version, that we are 100% sure works. After this didn’t do, we just created a branch from the same version, so we know, that it’s not git reverts problem.

We were wrong again. Now, when I enter the home directory of the git repo, and try to start the server, i get this:

Then it just stops. I didn’t find much about this error, to be exact, i found nothing. Is there any hope to recover from this? Or we should just start from scratch? I managed to install grafana from .deb file, and the server opened, but we still want to recover our project.

Thanks in advance for any help

welcome to the :grafana: forum, @tymon007

unfortunately, I’m not sure how much help the community can provide. I am happy to report that a large internationalization effort is underway at Grafana, but it is still a young project.

I’m curious, what repo did you use? This one?